Bazat e rrugëtimit – Basics of Routing

Rrugëtimi (Routing) është baza funksionale që kryhet nga pajisjet e shtresës së 3-të (Sipas sistemit të referimit OSI) dhe lejon dy nyje A dhe B, pa lidhje direkte, të komunikojnë me njëra-tjetrën nëpërmjet bashkëpunimit të nyejve të tjera të vendosura në gjurmën (Path) e rrjetit që lidh pikën A dhe B.

Figura 1.1 Rrugëtimi

Figura 1.1 Rrugëtimi

Si rrjedhim, detyra e shtresës së Network është transmetimi i paketave midis dy nyjave (Host) të çfarëdoshme, të cilat në përgjithësi nuk janë drejtpërdrejt të lidhura me njëra-tjetrën. Në modelin OSI, software i shtresës Network është prezent në secilën nyje të rrjetit, ndërkohë që software i shtresave më të larta është prezent vetëm në nyjat fundore. Të detajuara, funksionet e shtresës Network janë:

  • Forwarding (Përcjellja): ose marrja e një pakete në një portë, ruajtja e saj dhe ri-transmetimi në një portë tjetër. Ky funksion është prezent në të gjitha nyjat e Network dhe mund të përfshijë përdorimin e protokolleve të tjera të rrjetit.
  • Fragmentation (Copëtimi): nëse një paketë në mbërritje është shume e madhe për rrjetin në te cilin do të transmetohet, shtresa e Network e ndan atë në copë dhe kujdeset për ta ri-paketuar copat që mbërrijnë në kohën e dorëzimit.
  • Routing (Rrugëtimi): Përcakton udhën për transmetimin e të dhënave në Network. Në shumicën e rasteve ky funksion kryhet në mënyrë dinamike nga algoritmet speciale, të cilët analizojnë gjendjen e Network, tabelat e rrugëtimit, prioritetet e shërbimeve si dhe elemente të tjera dytësore.
  • Congestion Control (Kontrolli i Ngarkesës): për të pasur mundësinë për të dhënë prioritet me të lartë në të dhënat që janë më të rëndësishme
Figura 1.2. Qëllimi i rrugëzimit: ndërlidhja e rrjetave

Figura 1.2. Qëllimi i rrugëzimit: ndërlidhja e rrjetave

Rrugëtimi është i domosdoshëm kur rrjeti fillon të bëhet i larmishëm dhe nëse ju doni që:

  • Të jeni në gjendje të monitoroni dhe menaxhoni më mirë rrjetin;
  • Të bëni rrjetin më të sigurt sepse filtrat e firewal-itl bëhen më të thjeshta dhe më të plota:
  • Të përmirësoni efikasitetin duke përqendruar trafikun broadcast vetëm në subne-tin/rrjetin përkatës.
  • Të ndërlidhni së bashku rrjeta IP të ndryshme publike.
  • Të ndërlidhni Wide Area Network (WAN) te ndryshme (kompani, operatorë,.... )

Parimi në te cilin bazohet rrugëtimi IP-së është shumë i thjeshtë: dërgo paketat në udhën më të shkurtër për te destinacioni. Llogaria bëhet në mënyrë të shpërndarë nga router-at nëpërmjet një shkëmbimi informacioni mes tyre; në tabelën qe secili router ka dhe që tregohet drejtimi nga paketa duhet të marrë, vetëm router-i i radhës gjatë rrugës (next hop) tregohet, jo e gjithë rruga. Kjo qasje shfrytëzon veçorinë e grafikëve , sipas të cilëve edhe nënudhët e një udhe janë minimale.)

1.1 Klasifikimi i rrugëtimeve

Rrugëtimi, ose procesi për përcjelljen e paketave nga një rrjet në një rrjet tjetër mund të bëhet duke përdorur:

  • Rrugëtim Statik (Static routing) - Në këtë rast administratori konfiguron rrugëztimin manualisht duke përcaktuar çdo rrjet dhe destinacionin përkatës dhe duke e përsëritur këtë veprim për cdo router që ka në administrim në rrjetat e lidhura me njëra-tjetrën.

  • Rrugëtimi Dinamic (Dynamic Routing) – Në këtë rast administratori bën vetëm një konfigurim të thjeshtë me anë të të cilit aktivizon rutimin dinamik në secilin router dhe me pas routerat automatikisht kërkojnë per routera te tjerë dhe portat dalëse (gateway) nga të gjithë network e lidhur me njëri tjetrin.
Figura 1.3: Klasifikimi i protokolleve dinamik të rrugëzimeve

Figura 1.3: Klasifikimi i protokolleve dinamik të rrugëzimeve

1.2 Komponentët e rrugëtimit të RouterOS

Routeri mban informacionin e rrugëtimit në dy hapësira të ndara:

  • RIB (Routing Information Base)- është tabela e rrugëtimit
  • FIB (Forwarding Information Base) – është tabela që përdoret për kalimin ose përcjelljen e paketave.

1.2.1 Router Information Base (RIB)

Tabela e rrugëtimit është një tabelë të dhënash që në një router specifik rendit të gjitha rrugëtimet e njohura për një rrjet të caktuar. Për çdo rrugëtim tregohet metrika e cila përfaqëson koston që harxhohet gjatë rrugëtimit. Tabela e rutimit përbëhet nga:

  • Të gjitha rrugëtimet që krijohen nga protokollet dinamike të rutimit;
  • Të gjitha udhët per rrjetat e lidhura, qe janë për ndërfaqet e lidhura drejtpërdrejt me route-rin
  • Çdo rrugëtim i shtuar manualisht (rrugëtim statik)

Në RouterOS tabela e rutimit shfaqet duke shkuar në menunë IP>Route>List.

Figura 1.4 Tabela e Routimi (RIB)

Figura 1.4 Tabela e Routimi (RIB)

Tabela e rutimit përdoret që:

  • Të filtrojë informacionin e rrugëtimit për te gjitha tipet e protokolleve të rrugëtimit
  • Të llogarisë dhe zgjedhë rrugën më te mirë për një rrjet të caktuar
  • Të krijojë dhe mirëmbajë tabelën e përcjelljes (shiko sesionin 1.2.2)
  • Te shpërndajë informacionin e rrugëtimit duke përdorur protokollet dinamike të rrugëtimit

Për çdo rresht në tabelën e rrugëtimit ka shkronja që tregojnë statusin e rrugës në përputhje me shkurtesat që tregohen në tabelën 1.1

Veçoria

Treguesi

Përshkrimi

Disabled (çaktivizuar)

X

Kjo rrugë është çaktivizuar dhe nuk përdoret.

Active (aktive)

A

Kjo rrugë përdoret për të përcjellë paketa.

Dynamic (dinamike)

D

Kjo rrugë është krijuar automatikisht nga software-i. Nuk mund

të eksportohet apo modifikohet drejtpërdrejt .

Connected

C

Connected Route (Rrugë e drejtpërdrejtë)

static

S

Static Route (Rrugë e konfiguruar nga administratori)

rip

r

E krijuar nëpërmjet protokollit RIP

bgp

b

E krijuar nëpërmjet protokollit BGP

ospf

o

E krijuar nëpërmjet protokollit OSPF

mme

m

E krijuar nëpërmjet protokollit MME

blackhole

B

Paketat në drejtim të kësaj rruge nuk konsiderohen dhe nuk lajmërohet askush për këtë veprim


unreachable

U

Paketat në drejtim të kësaj rruge nuk merren parasysh, por lajmërohet me mesazh ICMP për këtë situate.

prohibited

P

Paketat në drejtim të kësaj rruge nuk merren parasysh, por lajmërohet me mesazh ICMP për këtë situate


Tabela 1.1: Treguesit që mund t’i bashkëngjiten një rruge

1.2.2 Forwarding Information Base (FIB)

Tabelat e rrugëtimit (RIB) në përgjithësi nuk përdoren drejtpërdrejt për përcjelljen e paketave; të dhënat në tabelën RIB përdoren për të krijuar tabela më të vogla dhe me specifike që quhen Forwarding Tables (Tabelat e Përcjelljes) FIB. Një tabelë përcjellje përmban vetëm udhën që zgjidhet nga algoritmi i rrugëtimit për të vazhduar rrugëtimin e paketës drejt destinacionit të saj. Kjo udhë është shpesh në formën e një memorie në një format të kompresuar ose të parallogaritur, në një format të optimizuar për arkivim dhe kërkim për pajisje specifike të router-it. Në pajisjet Cisco ky komponent quhet Cisco Express Forwarding (CEF).

Si rrjedhim mund të themi këto gjëra për tabelën e përcjelljes:

  • Është produkt i tabelës se rrugëtimit pasi ajo është filtruar
  • Është një kopje memorie (cached copy)
  • Të gjitha rrugët aktive janë në tabelën kryesore
  • Nëse etiketimet e rrugëve (routing marking) nuk janë përdorur të gjitha, rrugët e mirëqena (default routes) do të jenë në tabelën kryesore (shikoni me poshtë për të kuptuar këtë hap)
  • Ka vetëm një rregull të fshehtë dhe të nënkuptuar (“catch all” që i përfshin të gjitha) që përdor tabelën kryesore për të bërë kërkimet e interesuara.

1.2.3 Si përdoren tabelat RIB dhe FIB

FIB përdor informacionet e mëposhtme të paketës (IP paket) për të përcaktuar destinacionin e saj:

  • Adresën e burimit
  • Adresën e destinacionit
  • Ndërfaqen burim
  • Markimin ose routimin e mundshëm
  • ToS (type of service) – kjo fushë aktualisht nuk përdoret nga protokolli IPv4 nuk përdoret nga RouterOS në tabelën e rrugëtimit, por pjesë ne opsionet e kërkimit në memorine e rrugëtimit

Vendimet e mundshme të rrugëtimit janë:

  • Pranimi i paketës lokalisht
  • Shpërbërja e paketës (pa u marrë vesh ose duke kërkuar një mesazh ICMP tek ai që e dërgoi paketën )
  • Dërgoje paketën te një adresë IP specifike në një ndërfaqe specifike

Rezultati i vendimit të rrugëtimit ruhet në memorie (FIB) për të përmirësuar performancën e rrugëtimit. Kur një paketë me të njëjtën adresë burim, adrese destinacion, ndërfaqe burimi, etiketim rrugëtimi dhe ToS do të rrugëzohet, do të përdoret rezultati në memorie. Kjo lejon gjithashtu edhe implementimin e ndarjes së ngarkesës (load balancing) bazuar në lidhjet (ndarja e ngarkesës në bazë të lidhjeve/per connection load balancing) nëpërmjet rrugëve ECMP, sepse vlerat që përdoren për të kontrolluar hyrjet në rrugëtimet e memorizuara janë të njëjta për të gjitha paketat që i përkasin të njëjtës lidhje dhe që shkojnë në të njëjtin drejtim.

Nëse nuk ka një të dhënë në rrugëtimet e memorizuara per nje pakete atëherë ndodh procesi i mëposhtëm:

  • Kontrollohet nëse paketa duhet të dorëzohet lokalisht ( adresa destinacion është vetë router-i)
  • Ekzekutohen rregullat e rrugëtimit të nënkuptuara
  • Ekzekutohen rregullat e rrugëtimit që ka shtuar administratori
  • Ekzekutohet rregulli i nënkuptuar që i përfshin të gjitha dhe kërkon për destinacionin në tabelën kryesore të rrugëtimit)
  • Nëse të gjitha hapat e mësipërm dështojnë atëherë shfaqet rezultati “unreachable network” (rrjet i paarritshëm)
Figura 1.5 Forwarding Information Base (FIB)

Figura 1.5 Forwarding Information Base (FIB)

Regullat që nuk përkojnë me paketat konkrete injorohen. Nëse një rregull ka një veprim drop (shkatërro) ose unreachable (i paarritshëm) atëherë kjo arrihet si rezultat i një procesi rrugëtimi. Nëse veprimi është një kërkim, adresa destinacion e paketës do kërkohet në tabelën e rrugëtimit sipas specifikimit të rregullit. Nëse kërkimi dështon (nuk ka një rruge që përputhet me adresën destinacion të paketës) atëhet FIB vazhdon me rregullin tjetër. Ndryshe:

  • Nëse tipi i udhës është blackhole (vrimë e zeze), prohibited (e ndaluar) ose unreachable (e paarritshme), atëherë kryen veprimin si rezulatat i vendimit te rrugëtimit
  • Nëse është një rrugë direkte (connected route) ose një rrugë që ka caktuar një ndërfaqe si vlerë të portës dalëse (gateway), atëherë kthen si rezultat të vendimit të rrugëtimit këtë ndërfaqe dhe adresën destinacion te paketës
  • Nëse rruga ka një adresë IP si vlerë të ndërfaqes dalëse, atëherë kthen këtë adresë dhe ndëfaqen që lidhet me këtë adresë si rezultat të vendimit të rrugëtimit
  • Nëse rruga ka më shumë se një vlerë si hapin e radhës (nexthop), athëre kthen një prejt tyre në modën round robin si rezultat të rrugëtimit.

Rezultati i vendimeve të rrugëtimit ruhet në një hyrje të re të memories së rrugëtimit. Vini re se një vendim rrugëtimi nga procesi i përcaktuar jep si rezultat:

  • Adresën IP të ndërfaqes së radhës (next hop)
  • Një ndërfaqe tip pikë me pikë (point to point interface)
  • Dorëzim lokal
  • Shkatërrim
  • Mesazh ndalimi ICMP
  • Mesazh ICMP nyja e paarritshme
  • Mesazh ICMP rrjeti i paarritshëm
Figura 1.6. Ndërveprimi midis RIB dhe FIB

Figura 1.6. Ndërveprimi midis RIB dhe FIB

1.3 Rruga e Paracaktuar (Default Route)

Rruga me adresë destinacion 0.0.0.0/0 aplikohet te të gjitha adresat destinacion. Kjo udhë quhet rruga e paracaktuar (default route) dhe routeri i zgjedhur quhet ndërfaqe e paracaktuar (default gateway). Nëse tabela e rrugëtimit ka një rrugë të paracaktuar aktive atëherë kërkimi në tabelën e rrugëtimit do të jetë gjithmonë i suksesshëm. Analogjia në këtë rast është sikur udhëton në një qytet dhe gjen një shenjë rruge që tregon “te gjitha drejtimet”

1.4 Rrugët e lidhura / të drejtpërdrejta (connected routes)

Rrugët e lidhura krijohen automatikisht për çdo rrjet IP që ka të paktën një ndërfaqe të lidhur me router- in (si specifikohet në konfigurimin e adresave IP që konfigurohen). RIB ruan gjendjen e rrugëve të lidhura por nuk i ndryshon ato.

Për çdo rrugë të lidhur ka një adresë IP kështu që:

  • Adresa destinacion e rrjetit për një rrugë të lidhur është adresa IP e ndërfaqes së rrjetit.
  • Netmask-u i adresës destinacion të rrugës së lidhur është e njëjta me netmask-un e adresës IP të ndërfaqes.
  • Pref-src e rrugës se lidhur është e njëjta si adresa IP e ndërfaqes.
  • Ndërfaqja e rrugës se lidhur është e njëjtë me ndërfaqen në fjalë.

Shënim: Pamë që sa herë shtojmë një adresë IP në një ndërfaqe të vlefshme (ndërfaqe aktive) në rrugë e lidhur krijohet automatikisht. Duhet të vëmë re qe nëse janë dy adresa IP që vijnë nga i njëjti subnet dhe nga e njëjta ndërfaqe atëherë vetëm një udhë do të lidhet. Për këtë arsye është e rëndësishme që të mos vendosim dy adresa IP nga i njëjti subnet në dy ndërfaqe te ndryshme sepse do të ngatërrojmë RIB.

Për të njëjtën arsye sugjerohet që nëse një ndërfaqe ka më shumë se një adresë IP nga i njëjti subnet, vetëm adresa e parë tregohet me netmask-un e plotë ndërsa të tjerat do të tregohen me netmask-un

/32.

Figura 1.7 Korrespondenca ndërmjet adresave dhe rrugëve të lidhura

Figura 1.7 Korrespondenca ndërmjet adresave dhe rrugëve të lidhura

Siç përshkruhet në fillim të kapitullit, në Mikrotik RouterOS, rrugëzimet dinamike dhe statike janë të mundshme. Të parat krijohen automatikisht kur një adresë IP shtohet në një ndërfaqe ose kur informacioni i rrugëzimit vjen nga një protokoll dinamik siç janë RIP, OSPF dhe BGP. Rrugëzimet statike janë informacione rrugëzimi që shtohen manualisht nga administratori i rrjetit me qëllim përcaktimin e një udhe.

Rruga e paracaktuar (Default Route) është një shembull i pathit statik.

1.5 Rrugëzimi Statik

Rrugëzimi statik krijohet duke shtuar një konfigurim në RIB dhe duke përcaktuar një udhë statike për rrugëzimin e paketave, rrjetin destinacion dhe routerin/gateway (ndërfaqen dalëse) që do të përdoret për destinacionin në fjalë. Si ndërfaqe dalëse mund të përdoret:

  • Adresa IP
  • Ndërfaqja

Mos harroni nëse Adresa destinacion është përcaktuar si 0.0.0.0/0, te gjitha IP-te e internetit janë te përfshira ne udhën e paracaktuar qe krijuat

Janë të disponueshëm parametrat e mëposhtme kur shtohet një udhe statike:

  • Destinacioni;
  • Adresa destinacion dhe netmask ;
  • 0.0.0.0/0 nëse do te jete një udhë e paracaktuar
  • Gateway
  • Adresa IP e ndërfaqes dalëse, duhet te jete adresa IP e subnet me IP e konfiguruar në një nga ndërfaqet e routerit.
  • Ndërfaqja dalëse përdoret si gateway; kur adresa IP e ndërfaqes nuk dihet ose është dinamike, si për shembull në rastin e lidhjeve pikë më pikë ose lidhjeve seriale.
Figura 1.8: Konfigurimi i udhës statike

Figura 1.8: Konfigurimi i udhës statike

Burimi i preferuar:

  • Adresa IP e burimit të paketës që do të dalë nga routeri .
  • Zakonisht është adresa IP e konfiguruar në një ndërfaqe dalëse (gateway)

Distanca:

  • Përdoret për përllogaritjen e udhëve dhe përzgjedhjen e tyre.
  • Vlerat e mundshme janë nga 0 ne 255.
  • Me paracaktim vlerat vendosen nga protokolli i rrugëzimit dhe janë:
    • Udhët e drejtpërdrejta: 0
    • Udhët statike:               1
    • eBGP:                           20
    • OSPF                            110
    • RIP:                              120
    • MME:                           130
    • iBGP                             200
  • Shënim: distanca 255 nënkupton “reject” (refuzim të paketës)

Scope and Target Scope (Shtrirja dhe kufiri i shtrirjes)

  • Përdoret për kërkimin e deleguar të hopit të radhës (për me tepër lexoni temën 2.7 )

1.6 Laboratorë

Shënim: Para se të zhvilloni laboratorët e mëposhtëm, sigurohuni qe iu jeni përgjigjur siç duhet pyetjeve të këtij kapitulli.

1.6.1 Udhëzues - Rrugëzimi Statik

Qëllimi 1. —Konfigurimi i rrugëzimit statik të thjeshtë. Ky laborator ju jep mundësinë të rindërtoni infrastrukturën e rrjetit sipas figurës 1.9 dhe të verifikoni saktësinë e përgjigjeve, objektivi.

         1. Riktheni në konfigurimin e fabrikës routerin (pa konfigurimet e paracaktuara).
         2. Lidhni kompjuterët midis pjesëmarrësve bazuar në skemën më poshtë.
         3. Bëni konfigurimet e mëposhtme në routerin R1:

Figure 1.9: Rrjet me rrugëzim statik

Figure 1.9: Rrjet me rrugëzim statik

                  R1
                 
                  /ip address
                  add address=10.10 20.1/24 interface=ether1 network=10.10.20.0
                  add address=10.10 10.1/24 interface=ether2 network=10.10.10.0
                  add address=11.11 11.2/24 interface=ether3 network=11.11.11.0
                  /ip route add distance=1 dst-address=0.0.0.0/0 gateway=11.11.11.1
                  /system identity set name=R1

            4. Bëni konfigurimet e mëposhtme për routerin R2:

                  R2

                  /ip address
                  add address=11.11 11.1/24 interface=ether1 network=11.11.11.0
                  add address=22.22 22.2/24 interface=ether2 network=22.22.22.0
                  /ip route
                  add distance=1 dst-address=0.0.0.0/0 gateway=22.22.22.2
                  add distance=1 dst-address=10.10 10.0/24 gateway=11.11.11.2
                  add distance=1 dst-address=10.10 20.0/24 gateway=11.11.11.2
                  /system identity set name=R2

Laboratori është kryer saktë nëse është e mundur që ju të bëni ping të suksesshëm nga kompjuterët në drejtim të IP-së 22.22.22.2.

1.6.2 Rrugëzimi Statik - pa ndihmë

Qëllimi 2 - konfigurimi i rrugëzimit statik të thjeshtë. Ky laborator ju jep mundësinë të rindërtoni infrastrukturën e rrjetit sipas figurës 1.10 dhe të verifikoni saktësinë e përgjigjeve, pa ndihmë.

Kryeni veprimet e mëposhtme në mënyrë te pavarur:

  1. Riktheni në konfigurimin e fabrikës ruterin (pa konfigurimet e paracaktuara)
  2. Lidhni kompjuterët midis pjesëmarrësve bazuar në skemën më poshtë.
  3. Konfiguroni rrugëzimet statike në secilin router siç tregohet në diagramë.

Laboratori konsiderohet i kryer nëse keni ping midis kompjuterëve (merrni konsiderate çaktivizimin e Windows firewall, për të lejuar pingun)

Figure 1.10 Rrjet me rrugezim statik

Figure 1.10: Rrjet me rrugëzim statik

Zgjidhjet e laboratorëve:

R1

/system identity set name=R1
/ip address
add address=192.168.1.1/24 interface=ether1 network=192.168.1.0
add address=12.12.12.1/24 interface=ether2 network=12.12.12.0
/ip route
add distance=1 dst-address=23.23.23.0/24 gateway=12.12.12.2
add distance=1 dst-address=192.168.2.0/24 gateway=12.12.12.2
add distance=1 dst-address=192.168.3.0/24 gateway=12.12.12.2

R2

/system identity set name=R2
/ip address
add address=192.168.2.1/24 interface=ether1 network=192.168.2.0
add address=12.12.12.2/24 interface=ether2 network=12.12.12.0
add address=23.23.23.2/24 interface=ether3 network=23.23.23.0
/ip route
add distance=1 dst-address=192.168.1.0/24 gateway=12.12.12.1
add distance=1 dst-address=192.168.3.0/24 gateway=23.23.23.3

R3

/system identity set name=R3
/ip address
add address=192.168.3.1/24 interface=ether1 network=192.168.3.0
add address=23.23.23.3/24 interface=ether2 network=23.23.23.0
/ip route
add distance=1 dst-address=192.168.1.0/24 gateway=23.23.23.2
add distance=1 dst-address=192.168.2.0/24 gateway=23.23.23.2

Plotësoni Testin Para se të kaloni në kapitullin tjetër

Leave a Reply

Your email address will not be published. Required fields are marked

{"email":"Email address invalid","url":"Website address invalid","required":"Required field missing"}
Pen